Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Where is SimpleDrums?

I just installed KXStudio and updated to Muse 2.2. All is running fine!

Problem is, I can't find the SimpleDrums drum machine anywhere. I can access a lot of other softsynth, for example from MESS, DSSI, VST and LV2.

Or am I looking in the wrong place?


Tjena Staffan,

(01-17-2015, 04:35 PM)oscillator Wrote: Problem is, I can't find the SimpleDrums drum machine anywhere. I can access a lot of other softsynth, for example from MESS, DSSI, VST and LV2.

Hmm, that's odd. SimpleDrums should definitely be there under the MESS section.
You could check if the binary is there under the installation path.
I'm guessing it's either
There should be a file together with the other internal synths.

If it's there, start MusE from a commandline and see if there is any error reported related to simpledrums, possibly the -D argument to show more debug info is needed.
If the synth isn't there I think you need to ask on the kxstudio forum, maybe the build is done without some option to cause this.

Another way is to build MusE from source but do ask on the kxstudio forum also.

Thanks! is in usr > lib > muse > synthi

When I start from the command line (great tip!) one of the lines read

initMidiSynth: MESS dlopen(/usr/lib/muse/synthi/ failed: /usr/lib/muse/synthi/ undefined symbol: sf_close

sf_close is part of libsndfile, right?

I have libsndfile1 (1.0.25-7ubuntu2) installed.

Any ideas?

Indeed, I believe sf_close should belong to libsndfile1.
You could try running
ldd /usr/lib/muse/synthi/
it lists all library dependencies of the binary. It should list libsndfile1.
I haven't come across this problem so not sure what the remedy is though.

Maybe the libsndfile version you have isn't the one kxstudio expects? Have you tried making a full update of installed packages?
Tack igen!

Hmmm...ldd doesn't list libsndfile1... I'll try talking to the kxstudio people, maybe they have done something wrong.


Hej igen Staffan,

This is odd. I didn't actually check my so I did now, just be sure and mine doesn't list libsndfile either!
For some reason it works for me anyway..
It certainly looks like the root cause is ours, as far as I understand should really be linked with libsndfile.
I'll research this a bit more.

I have no idea why it works on some systems because the dependency was actually missing. I've added it now and it looks correct.

If you have the possibility to try building the latest from git I'd appreciate it.
We'll probably make a bugfix release in a while but there's none planned yet.

Great, thanks!

Currently building the master branch (right?). I will report back!

Tack för all hjälp! Smile


Yes, this fixed the bug with SimpleDrums not showing uo in the MESS menu. Great!

Unfortunately, some other things (JACK communication etc) seemed a bit flaky, so I will wait for the bug fix version! Smile

Thanks again!

Great that it fixed it.

Though, what happens with Jack?
I'm not aware of any fixes or known bugs with Jack so if you could fill me in I will take a look.

Unfortunately I have re-installed KXStudio on my machine so I am not able to reproduce.

But the problem was that after a couple of minutes of running the compiled/patched Muse 2.2, Jack informed me that I had disconnected Muse due to performance problems (I've never seen that one before).

Maybe I missed some flags or libraries during compilation? I used the .sh-script, but I remember that the script mentioned that I missed support for Python and one other thing. Sorry.

Forum Jump:

Users browsing this thread: 1 Guest(s)