Thread Rating:
  • 1 Vote(s) - 4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
LV2 GTK2 ui support is not available
(03-25-2016, 02:46 AM)jgiles10014 Wrote: and then the GUI crashes.  I've found one reference on the mailing list, about recompiling lv2Gtk2Helper, which I did try with an error "make: Nothing to be done for 'all'."  I am not sure how to fix it, and hopefully someone here might be able to give me a clue.  Thanks!


Hi jg,

Indeed you need to recompile the helper .so files. They are prebuilt for x86 and x64 as a means for sparing people to track down all the dependencies.
I believe the makefile has been improved in current git so it might be a bit more user friendly there. Btw, git is getting ready for release so I would recommend using that instead of 2.2.1.

It seems you found the correct dir. I tried now to compile it with 2.2.1 and I had to remove the *.so files in the folder before it tried to compile.
You also need the development packages for gtkmm (libgtkmm2.4-dev for me) and all it's dependencies.

After this do: make

If you have a 64-bit raspberry you can do make without arguments.

Hope that helps,

Messages In This Thread
RE: LV2 GTK2 ui support is not available - by spamatica - 03-25-2016, 10:37 AM

Forum Jump:

Users browsing this thread: 1 Guest(s)