Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Jack problems with MIDI interface
I have a problem when using Jack, (QjackCtl which is bundled with ubuntustudio) - it was fine up until a few days ago when firing up MusE sequencer, however whats happened is 'system' has suddenly disappeared from the MIDI section as in the screenshot. basically means i cannot play anything through my midi device (Miditerminal M8U)

I tried to get around it by running muse with -A command but whilst i can reconfigure all the midi ports through ALSA, it plays all the wrong notes!

Is there anyway i can get it working like it used to, with 'system' able to show up again in the MIDI window?

Screenshot here:

Works fine with the audio side (system shows up)

And all the midi interfaces show up on the ALSA tab:

many thanks Smile

This is usually means, that in Qjackctl settings midi driver is set to "none". Set it to "raw" and system midi group should appear again (I hope Smile ).

Thanks for that Andrew, I think i might have tried that last night (but cant quite remember in the moment of haste) and was still getting issues.

However, today i switches on, ready for another day of head scratching, but this time I decided first to run qjackctl from command and it fires up perfectly. system is now showing again in midi pane, and pulseaudio again in audio. couple of patching reconfigs with muse (i think where my messing around messed up some of the patching) and all is working perfect once again.

So i dont know what happened there, by starting jack in terminal seems to have fixed it. Even restarting comp and firing up muse on its own is all ok now. midi driver is on 'raw' as we speak so that might have been it. Shall make sure of that from now on.

Either way, its happy days Big Grin Thanks again!
Ok, nice to hear, that everything is all right! Smile

Forum Jump:

Users browsing this thread: 1 Guest(s)