Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
EXECUTING muse2 stops on error
#1
Hello,

I use a stanbdard OpenSuSE 11.4 Linux on a Intel 32 bit System
After compiling w.o. any problems,
I try to start muse2.

As I switch verbose mode in qjackctl
I receive these error messages:

===================
hafi@wallee:~/Dokumente/prj/PHYSIK/EAKUSTIK/JACK> muse2
Denormal protection enabled.
Jack: JackClient::SetupDriverSync driver sem in flush mode
Jack: JackPosixSemaphore::Connect jack_sem.500_default_MusE
Jack: Already connected name = MusE
Jack: Clock source : system clock via clock_gettime
Jack: JackLibClient::Open name = MusE refnum = 3
Jack: jack_set_graph_order_callback ext_client 81b3428 client 81b3428
Jack: SetGraphOrderCallback
Jack: jack_set_thread_init_callback ext_client 81b3428 client 81b3428
Speicherzugriffsfehler
===================

What is wrong???

Yours,
- Willy <!-- sBig Grin --><img src="{SMILIES_PATH}/icon_e_biggrin.gif" alt="Big Grin" title="Very Happy" /><!-- sBig Grin -->
Reply
#2
Hi Willy,

please try running ulimit -c unlimited before starting muse.
This way you should get a core file which you can inspect with gdb muse2 core and then backtrace at the prompt, hopefully that will tell us what is going on.

Regards,
Robert
Reply
#3
I di a

ulimit -c unlimited
gdb muse2 core
and got thjis backtrace output.
=====================================
(gdb) backtrace
#0 0xb587ea31 in free () from /lib/libc.so.6
#1 0xb5a72b0f in operator delete(void*) () from /usr/lib/libstdc++.so.6
#2 0xb5a72b6b in operator delete[](void*) () from /usr/lib/libstdc++.so.6
#3 0xa14e2243 in Config::~Config() () from /usr/lib/dssi/zynaddsubfx.so
#4 0xb583ac1b in __cxa_finalize () from /lib/libc.so.6
#5 0xa14d49e4 in ?? () from /usr/lib/dssi/zynaddsubfx.so
#6 0xa152db50 in _fini () from /usr/lib/dssi/zynaddsubfx.so
#7 0xb77c5435 in _dl_close_worker () from /lib/ld-linux.so.2
#8 0xb77c5ec8 in _dl_close () from /lib/ld-linux.so.2
#9 0xb5c0ed02 in dlclose_doit () from /lib/libdl.so.2
#10 0xb77c05ff in _dl_catch_error () from /lib/ld-linux.so.2
#11 0xb5c0f342 in _dlerror_run () from /lib/libdl.so.2
#12 0xb5c0ed38 in dlclose () from /lib/libdl.so.2
#13 0xb7650c94 in loadPluginDir(QString const&) () from /usr/local/lib/muse-2.0alpha/modules/libmuse_core.so
#14 0x00000001 in ?? ()
#15 0xbff2de3c in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)
Reply
#4
Hi,

Ah, yes, we have just been discussing the zynaddsubfx-dssi synth, for some reason it does not work in muse2.
If you start muse with -I it won't load dssi plugins, then it should start OK.
Zyn is a good synth, we need to find out what the problem is... this far it unfortunately looks like the problem is in Zyn

Regards,
Robert
Reply
#5
Robert,

Actually, MusE 2 has difficulty handing quite a few plug-ins not just ZynAddSubFX. Can users expect to see MusE 2 handle Steinberg VSTs running under WINE a la QTractor, Rosegarden? Thanks, everyone!
Reply
#6
Hi,
sorry for the delay.

Quote:Actually, MusE 2 has difficulty handing quite a few plug-ins not just ZynAddSubFX. Can users expect to see MusE 2 handle Steinberg VSTs running under WINE a la QTractor, Rosegarden? Thanks, everyone!

MusE currently uses the same solution as atleast Rosegarden does so, yes, the same plugins should work.
I'd be happy to know of any that work in the others but not in MusE.

The ZynAddSubFX problem has been isolated by Willy and should now be fixed in current svn.

Regards,
Robert
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)