MusE Sequencer forum
Can't understand double play midi - Printable Version

+- MusE Sequencer forum (http://muse-sequencer.org/forum)
+-- Forum: MusE Forum (http://muse-sequencer.org/forum/forumdisplay.php?fid=5)
+--- Forum: Getting Help (http://muse-sequencer.org/forum/forumdisplay.php?fid=3)
+--- Thread: Can't understand double play midi (/showthread.php?tid=33)



Can't understand double play midi - nerak99 - 02-05-2012

I am trying to get to grips with Muse and have successfully recorded some midi stuf from a keyboard but I am not sure I am doing it right.
(I use QJackctl and all seems to connect OK)
I set up tracks, a midi track and a fluidsynth track, there is an out track there by default.

So far as I can tell, I get events into the sequencer by setting the Midi track to the usb keyboard.
In order to hear the track, I change the Midi track to fluid synth and play.
Two problem, first of all, whatever I recorded gets played twice and second, I would have thought that I should be able to hear as I play.I can only get the mid sequencer to record if I select the single note button, otherwise, it seems to ignore ,my keyboard.

Can someone point me to the correct part of the docs to get a midi keyboard playing live and recording in the piano roll at the same time?


Re: Can't understand double play midi - term356 - 02-13-2012

"So far as I can tell, I get events into the sequencer by setting the Midi track to the usb keyboard. "
Mm... Yes, but by clicking on the 'Input Routes' button on the midi Track Info panel.
There you can tell MusE from which devices and channels to record from.

"In order to hear the track, I change the Midi track to fluid synth and play."
Mm... Yes by clicking on the midi track's 'Port' column of the Arranger Track List.
But this is not to imply that you have to keep switching it between usb when recording and fluidsynth when playing.
Leave that setting on fluidsynth, and as described above, choose your input devices and channels.
In the case of synths, also make sure the 'Midi Thru' button (red arrow) is always on.
Then hit the track's 'Record Arm' light (red LED) in the Arranger Track List.
Then hit rec+play on the transport and it will now be recording and you hear it as you play.

"Two problem, first of all, whatever I recorded gets played twice and second, I would have thought that I should be able to hear as I play.I can only get the
mid sequencer to record if I select the single note button, otherwise, it seems to ignore ,my keyboard."
In order to hear live, as I mention above, hit the track's 'Record Arm' light (red LED) in the Arranger Track List.
Double notes? Hm this sounds like you are getting some kind of midi echo. When a track's output port is a synth, this should not happen.
Check your signal flow especially as I said you don't need to keep changing the output port to usb.
Please send a .med file with the problem if you still have trouble. I can look at it and see what might be wrong.

"Can someone point me to the correct part of the docs to get a midi keyboard playing live and recording in the piano roll at the same time?"
Not sure about docs but there is an example template called synti.med when you click 'New'.

Any luck yet, in the week since you posted?
Tim.