MusE Sequencer forum
Specify 64 Bit Installation Directory - Printable Version

+- MusE Sequencer forum (http://muse-sequencer.org/forum)
+-- Forum: MusE Forum (http://muse-sequencer.org/forum/forumdisplay.php?fid=5)
+--- Forum: Getting Help (http://muse-sequencer.org/forum/forumdisplay.php?fid=3)
+--- Thread: Specify 64 Bit Installation Directory (/showthread.php?tid=18)



Specify 64 Bit Installation Directory - tpreitzel - 06-26-2011

Robert, et al:

Thanks for the newly reworked MusE for QT4! I've been waiting. <!-- sWink --><img src="{SMILIES_PATH}/icon_e_wink.gif" alt="Wink" title="Wink" /><!-- sWink -->

BTW, how does one change the installation directory for the libraries using cmake?

I tried to specify the option -DLIB_SUFFIX=64 to cmake, but the libraries are ALWAYS installed to /usr/lib instead of /usr/lib64 ... Obviously, I'm doing something wrong.

TIA


Re: Specify 64 Bit Installation Directory - Guest - 06-26-2011

I've even tried installing libraries to /usr/lib64 using the option, -DLIB_INSTALL_DIR=lib64, but the libraries are still installed to /usr/lib instead of /usr/lib64


Re: Specify 64 Bit Installation Directory - spamatica - 07-12-2011

Hi!

Sorry for the delay.
I haven't tested this myself, googling a bit turned up this:
cmake -DLIB_SUFFIX=64 .
from here <!-- m --><a class="postlink" href="http://www.mail-archive.com/boost-cmake@lists.boost.org/msg00588.html">http://www.mail-archive.com/boost-cmake ... 00588.html</a><!-- m -->

Hope it works for you.

Regards,
Robert


Re: Specify 64 Bit Installation Directory - tpreitzel - 01-19-2012

Robert,

LIB_SUFFIX=64 isn't enough. One has to add the environment variable, CMAKE_INSTALL_LIBDIR=/usr/lib64, in order for muse-2.0 to compile on 64 bit GNU/Linux with the libraries in /usr/lib64 .

For example, cmake -DCMAKE_INSTALL_PREFIXTongueATH=/usr -DLIB_SUFFIX=64 -DCMAKE_BUILD_TYPE=Release -DLOCALSTATE_INSTALL_DIR=/var -DSYSCONF_INSTALL_DIR=/etc -DCMAKE_INSTALL_LIBDIR=/usr/lib64 , for Slackware64 ...

I HTH


Re: Specify 64 Bit Installation Directory - spamatica - 01-23-2012

Okay thanks for the information. I'll send it along to the mailinglist and see if any other dev has something to add.

Reading my previous reply I don't know what I was thinking... the same as you had tried right?

Regards,
Robert


Re: Specify 64 Bit Installation Directory - tpreitzel - 01-28-2012

spamatica Wrote:Okay thanks for the information. I'll send it along to the mailinglist and see if any other dev has something to add.

Reading my previous reply I don't know what I was thinking... the same as you had tried right?

Regards,
Robert

Right.


Re: Specify 64 Bit Installation Directory - term356 - 02-12-2012

Hello. Late to the discussion, sorry.

Researched: CMAKE_INSTALL_LIBDIR is apparently accepted (as you've shown),
but not defined so it does not automatically show up in say, ccmake gui.

Here are the lines from the top of our top-level CMakeLists.txt:

# set libdir if not use -DCMAKE_INSTALL_LIBDIR
if (NOT CMAKE_INSTALL_LIBDIR)
SET(CMAKE_INSTALL_LIBDIR "${CMAKE_INSTALL_PREFIX}/lib")
endif (NOT CMAKE_INSTALL_LIBDIR)

So if you say CMAKE_INSTALL_LIBDIR works for you, that's good to know it works. Is it all we can do?
I guess I should put that important piece of information in the README, since users won't see that option (I didn't see it).

Tim.


Re: Specify 64 Bit Installation Directory - term356 - 02-13-2012

Oh, on second glance and a few hours more research ...

CMake build system: Added cached variable LIB_PATH_SUFFIX, may be set to 64 so that installed library path is lib64 or whatever.
It should show up in the cmake guis.
In the SVN release_2_0 branch now.

Here's how I changed our top CMakeLists.txt. If you spot, or have, any problems please let me know !

if (NOT LIB_PATH_SUFFIX)
SET(LIB_PATH_SUFFIX "" CACHE STRING "Suffix for installed library path. Ex. 64 for lib64")
endif (NOT LIB_PATH_SUFFIX)

# set libdir if not use -DCMAKE_INSTALL_LIBDIR
if (NOT CMAKE_INSTALL_LIBDIR)
SET(CMAKE_INSTALL_LIBDIR "${CMAKE_INSTALL_PREFIX}/lib${LIB_PATH_SUFFIX}")
endif (NOT CMAKE_INSTALL_LIBDIR)

Thanks. Tim.